Read the docs
TI-2024-02775 Aliases CVE-2024-2968GHSA-x5jp-245w-xc3w

WP-Eggdrop <= 0.1 - Authenticated (Admin+) Stored Cross-Site Scripting

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP-Eggdrop plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00319 25th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
backieWP-Eggdropup to 0.1—No fix listedCNA
  • WP-Eggdrop Vendorbackie Affected up to 0.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:backie:wp-eggdrop:0.1:*:*:*:*:wordpress:*:*0.1Vulnerablebackie
  • cpe:2.3:a:backie:wp-eggdrop:0.1:*:*:*:*:wordpress:*:* Versions 0.1 Vulnerable ·backie

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-2968
  2. 2026-10-03 Alias added: GHSA-x5jp-245w-xc3w

References

  • TI-2024-02776 WP-Eggdrop <= 0.1 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 5.4

Sources