Floating Chat Widget < 3.1.9 - Editor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button WordPress plugin before 3.1.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button | before 3.1.9 | 3.1.9 | Patch available | CNA |
- Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button VendorUnknown Affected before 3.1.9 Fixed in 3.1.9 Patch available CNA
Remediation
- Fix · CNA Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button (Unknown) Fixed in 3.1.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2972
- 2026-10-03 Alias added: GHSA-v2xc-vg4h-28jp
References
More premio Floating Chat Widget vulnerabilities
- TI-2024-03862 Floating Chat Widget < 3.2.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2025-01246 Cross-site scripting in premio Floating Chat Widget: Contact Chat Icons, Telegram Chat… CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-2972 · CVE Program
- CVE-2024-2972 · NVD
- FIRST EPSS
- GHSA-v2xc-vg4h-28jp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences