Qdrant Full Snapshot REST API snapshots.rs path traversal
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability was found in Qdrant up to 1.6.1/1.7.4/1.8.2 and classified as critical. This issue affects some unknown processing of the file lib/collection/src/collection/snapshots.rs of the component Full Snapshot REST API. The manipulation leads to path traversal. Upgrading to version 1.8.3 is able to address this issue. The patch is named 3ab5172e9c8f14fa1f7b24e7147eac74e2412b62. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-258611.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Qdrant | 1.6.0; 1.6.1; 1.7.0; 1.7.1; 1.7.2; 1.7.3; 1.7.4; 1.8.0; 1.8.1; 1.8.2 | — | No fix listed | CNA |
- Qdrant Vendor— Affected 1.6.0; 1.6.1; 1.7.0; 1.7.1; 1.7.2; 1.7.3; 1.7.4; 1.8.0; 1.8.1; 1.8.2 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3078
- 2026-10-03 Alias added: GHSA-5gxc-9wh2-99f9
References
More Qdrant vulnerabilities
- TI-2024-02062 Path Traversal and Arbitrary File Upload Vulnerability in qdrant/qdrant CVSS 3.0CRITICAL 9.8
- TI-2024-03573 Arbitrary File Read and Write during Snapshot Recovery in qdrant/qdrant CVSS 3.1CRITICAL 9.1
- TI-2024-03341 Path Traversal in qdrant/qdrant CVSS 3.1HIGH 7.5
- TI-2026-20730 Qdrant affected by arbitrary file write via `/logger` endpoint CVSS 3.1HIGH 8.8
- TI-2023-20226 * Buffer Overflow vulnerability in qdrant v.1.3.2 allows a remote attacker cause a denial… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-3078 · CVE Program
- CVE-2024-3078 · NVD
- FIRST EPSS
- GHSA-5gxc-9wh2-99f9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences