H5P < 1.15.8 - Contributor+ Stored XSS
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Interactive Content WordPress plugin before 1.15.8 does not validate uploads which could allow a Contributors and above to update malicious SVG files, leading to Stored Cross-Site Scripting issues
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00315 24th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Interactive Content (Unknown): 1.15.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Interactive Content | before 1.15.8 | 1.15.8 | Patch available | CNA |
- Interactive Content VendorUnknown Affected before 1.15.8 Fixed in 1.15.8 Patch available CNA
Remediation
- Fix · CNA Interactive Content (Unknown) Fixed in 1.15.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3111
- 2026-10-03 Alias added: GHSA-p658-759g-r8hf
References
Sources
- CVE-2024-3111 · CVE Program
- CVE-2024-3111 · NVD
- FIRST EPSS
- GHSA-p658-759g-r8hf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences