Cross-Site Scripting (XSS) Vulnerability in mintplex-labs/anything-llm
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) vulnerability exists in mintplex-labs/anything-llm, affecting both the desktop application version 1.2.0 and the latest version of the web application. The vulnerability arises from the application's feature to fetch and embed content from websites into workspaces, which can be exploited to execute arbitrary JavaScript code. In the desktop application, this flaw can be escalated to Remote Code Execution (RCE) due to insecure application settings, specifically the enabling of 'nodeIntegration' and the disabling of 'contextIsolation' in Electron's webPreferences. The issue has been addressed in version 1.4.2 of the desktop application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mintplex-labs | mintplex-labs/anything-llm | before 1.4.2 | 1.4.2 | Patch available | CNA |
- mintplex-labs/anything-llm Vendormintplex-labs Affected before 1.4.2 Fixed in 1.4.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mintplexlabs:anythingllm_desktop:*:*:*:*:*:*:*:* | before 1.4.2 | Vulnerable | mintplex-labs |
| cpe:2.3:a:mintplexlabs:anythingllm_docker:*:*:*:*:*:*:*:* | up to 1.2.0 | Vulnerable | mintplex-labs |
- cpe:2.3:a:mintplexlabs:anythingllm_desktop:*:*:*:*:*:*:*:* Versions before 1.4.2 Vulnerable ·mintplex-labs
- cpe:2.3:a:mintplexlabs:anythingllm_docker:*:*:*:*:*:*:*:* Versions up to 1.2.0 Vulnerable ·mintplex-labs
Remediation
- Fix · CNA mintplex-labs/anything-llm (mintplex-labs) Fixed in 1.4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3166
- 2026-10-03 Alias added: GHSA-g2q4-9pcj-78cw
References
More mintplex-labs Anythingllm Desktop vulnerabilities
- TI-2024-07601 Missing Authentication for Critical Function in mintplex-labs/anything-llm CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-3166 · CVE Program
- CVE-2024-3166 · NVD
- FIRST EPSS
- GHSA-g2q4-9pcj-78cw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences