Cross-site scripting in Concrete CMS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS version 9 below 9.2.8 and previous versions below 8.5.16 is vulnerable to Stored XSS in blocks of type file. Stored XSS could be caused by a rogue administrator adding malicious code to the link-text field when creating a block of type file. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concrete5/concrete5 (Packagist) | 9.0.0RC1 to before 9.2.8 | 9.2.8 | Patch available | GHSA-9qhc-pg6j-wf23 |
| — | concrete5/concrete5 (Packagist) | before 8.5.16 | 8.5.16 | Patch available | GHSA-9qhc-pg6j-wf23 |
- concrete5/concrete5 (Packagist) Vendor— Affected 9.0.0RC1 to before 9.2.8 Fixed in 9.2.8 Patch available GHSA-9qhc-pg6j-wf23
- concrete5/concrete5 (Packagist) Vendor— Affected before 8.5.16 Fixed in 8.5.16 Patch available GHSA-9qhc-pg6j-wf23
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 8.5.16; 9.0.0 to before 9.2.8 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 8.5.16; 9.0.0 to before 9.2.8 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-9qhc-pg6j-wf23 concrete5/concrete5 (Packagist) Fixed in 9.2.8 Advisory →
- Fix · GHSA-9qhc-pg6j-wf23 concrete5/concrete5 (Packagist) Fixed in 8.5.16 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Concrete CMS 8.5.16, 9.2.8
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2024-02981 Cross-site scripting in Concrete CMSPriority LOW 22
- TI-2024-02979 Cross-site scripting in Concrete CMSPriority LOW 22
- TI-2024-02978 Cross-site scripting in Concrete CMSPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3180
- 2026-10-03 Alias added: GHSA-9qhc-pg6j-wf23
References
Other 5
- https://documentation.concretecms.org/developers/introduction/version-history/8516-release-notes?_gl=1*1oa3zn1*_ga*MTc1NDc0Njk2Mi4xNzA2ODI4MDU1*_ga_HFB3HPNNLS*MTcxMjE2NjYyNi4xMy4xLjE3MTIxNjY3MDcuMC4wLjA.
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/928-release-notes?_gl=1*1bcxp5s*_ga*MTc1NDc0Njk2Mi4xNzA2ODI4MDU1*_ga_HFB3HPNNLS*MTcxMjE2NjYyNi4xMy4xLjE3MTIxNjY2ODEuMC4wLjA.
- https://github.com/concretecms/concretecms/commit/822e689cefe1eb876e9de31dad9ce660f3b5c295
- https://github.com/concretecms/concretecms/commit/e85ef2408a5eea7d5646178fbef0ab243baaed8f
- https://github.com/concretecms/concretecms
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-3180 · CVE Program
- CVE-2024-3180 · NVD
- FIRST EPSS
- GHSA-9qhc-pg6j-wf23 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences