Cross-site scripting in unitecms Unlimited Elements For Elementor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's text field widget in all versions up to, and including, 1.5.107 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Please note that this vulnerability is different in that the issue stems from an external template. It appears that older version may also be patched due to this, however, we are choosing 1.5.108 as the patched version since that is the most recent version containing as known patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unitecms | Unlimited Elements For Elementor | up to 1.5.107 | — | No fix listed | CNA |
- Unlimited Elements For Elementor Vendorunitecms Affected up to 1.5.107 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:unlimited-elements:unlimited_elements_for_elementor:*:*:*:*:*:wordpress:*:* | before 1.5.108 | Vulnerable | Unlimited Elements |
- cpe:2.3:a:unlimited-elements:unlimited_elements_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 1.5.108 Vulnerable ·Unlimited Elements
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3190
References
More unitecms vulnerabilities
- TI-2023-06162 Unlimited Elements for Elementor <= 1.5.89 - Authenticated(Contributor+) Remote Code Execution via template import CVSS 3.1HIGH 8.8
- TI-2023-03084 Unrestricted file upload in unitecms Unlimited Elements For Elementor CVSS 3.1HIGH 8.8
- TI-2024-05859 Blox Page Builder <= 1.0.65 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-02861 SQL injection in unitecms Unlimited Elements For Elementor CVSS 3.1HIGH 8.8
- TI-2026-04056 Path traversal in unitecms Unlimited Elements For Elementor CVSS 3.1HIGH 7.5
- TI-2025-13220 Doubly <= 1.0.46 - Authenticated (Subscriber+) PHP Object Injection via ZIP File Import CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences