WordPress Menu Plugin — Superfly Responsive Menu <= 5.0.29 - Cross-Site Request Forgery to Arbitrary File Deletion
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| looks_awesome | WordPress Menu Plugin — Superfly Responsive Menu | up to 5.0.29 | — | No fix listed | CNA |
- WordPress Menu Plugin — Superfly Responsive Menu Vendorlooks_awesome Affected up to 5.0.29 Fixed in — No fix listed CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:looks_awesome:superfly_responsive_menu:*:*:*:*:*:*:*:* | — | — | looks_awesome |
- cpe:2.3:a:looks_awesome:superfly_responsive_menu:*:*:*:*:*:*:*:* Versions — — ·looks_awesome
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3238
- 2026-10-03 Alias added: GHSA-8hj3-fhcj-rg42
References
More looks_awesome vulnerabilities
- TI-2025-23405 WordPress Team Builder plugin <= 1.5.7 - Broken Access Control Vulnerability CVSS 3.1HIGH 7.6
- TI-2024-21440 WordPress Superfly Menu plugin <= 5.0.25 - Subscriber+ Site-Wide Stored Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-33279 WordPress OnionBuzz plugin <= 1.0.7 - Cross Site Request Forgery (CSRF) Vulnerability CVSS 3.1HIGH 7.1
- TI-2025-12672 Missing authorization in looks_awesome Flow-Flow Social Feed Stream CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-3238 · CVE Program
- CVE-2024-3238 · NVD
- FIRST EPSS
- GHSA-8hj3-fhcj-rg42 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences