Zita Elementor Site Library <= 1.6.2 - Missing Authorization to Page Creation and Options Modification
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Zita Elementor Site Library plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the import_xml_data, xml_data_import, import_option_data, import_widgets, and import_customizer_settings functions in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to create pages, update certain options, including WooCommerce page titles and Elementor settings, import widgets, and update the plugin's customizer settings and the WordPress custom CSS. NOTE: This vulnerability was partially fixed in version 1.6.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3249
- 2026-10-03 Alias added: GHSA-f75m-4rx3-qhq8
References
More wpzita vulnerabilities
- TI-2024-24924 WordPress Zita Elementor Site Library plugin <= 1.6.1 - Arbitrary Code Execution vulnerability CVSS 3.1CRITICAL 9.9
- TI-2024-08284 Zita Elementor Site Library <= 1.6.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload CVSS 3.1MEDIUM 6.4
- TI-2025-02243 Z Companion <= 1.1.1 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload CVSS 3.1MEDIUM 6.4
- TI-2025-22087 WordPress Z Companion plugin <= 1.0.13 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
- TI-2026-20437 WordPress Zita Elementor Site Library plugin <= 1.6.6 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-3249 · CVE Program
- CVE-2024-3249 · NVD
- FIRST EPSS
- GHSA-f75m-4rx3-qhq8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences