FooBox (Free and Premium) < 2.7.28 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Lightbox & Modal Popup WordPress Plugin WordPress plugin before 2.7.28, foobox-image-lightbox-premium WordPress plugin before 2.7.28 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Lightbox & Modal Popup WordPress Plugin | before 2.7.28 | 2.7.28 | Patch available | CNA |
| Unknown | foobox-image-lightbox-premium | before 2.7.28 | 2.7.28 | Patch available | CNA |
- Lightbox & Modal Popup WordPress Plugin VendorUnknown Affected before 2.7.28 Fixed in 2.7.28 Patch available CNA
- foobox-image-lightbox-premium VendorUnknown Affected before 2.7.28 Fixed in 2.7.28 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fooplugins:foobox:*:*:*:*:-:wordpress:*:* | before 2.7.28 | Vulnerable | fooplugins |
| cpe:2.3:a:fooplugins:foobox:*:*:*:*:premium:wordpress:*:* | before 2.7.28 | Vulnerable | fooplugins |
- cpe:2.3:a:fooplugins:foobox:*:*:*:*:-:wordpress:*:* Versions before 2.7.28 Vulnerable ·fooplugins
- cpe:2.3:a:fooplugins:foobox:*:*:*:*:premium:wordpress:*:* Versions before 2.7.28 Vulnerable ·fooplugins
Remediation
- Fix · CNA Lightbox & Modal Popup WordPress Plugin (Unknown) Fixed in 2.7.28
- Fix · CNA foobox-image-lightbox-premium (Unknown) Fixed in 2.7.28
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3276
- 2026-10-03 Alias added: GHSA-w3hx-hrcp-gr58
References
More fooplugins Foobox vulnerabilities
- TI-2025-04977 Lightbox & Modal Popup WordPress Plugin – FooBox <= 2.7.34 - Authenticated (Author+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-3276 · CVE Program
- CVE-2024-3276 · NVD
- FIRST EPSS
- GHSA-w3hx-hrcp-gr58 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences