Dreamer CMS ThemesController.java ZipUtils.unZipFiles path traversal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability was found in Dreamer CMS up to 4.1.3.0. It has been declared as critical. Affected by this vulnerability is the function ZipUtils.unZipFiles of the file controller/admin/ThemesController.java. The manipulation leads to path traversal. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.3.1 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-259369 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3311
- 2026-10-03 Alias added: GHSA-96rw-9jfw-gw2m
References
More Dreamer Cms vulnerabilities
- TI-2023-25324 Dreamer CMS before version 4.0.1 is vulnerable to Directory Traversal. CVSS 3.1CRITICAL 9.1
- TI-2023-26681 Dreamer CMS v4.1.3 was discovered to contain a Cross-Site Request Forgery (CSRF) via the component /admin/archives/edit. CVSS 3.1HIGH 8.8
- TI-2023-25325 In Dreamer CMS before 4.0.1, the backend attachment management office has an Arbitrary File Download vulnerability. CVSS 3.1HIGH 7.5
- TI-2024-16954 An access control issue in Dreamer CMS v4.0.1 allows attackers to download backup files and leak sensitive information. CVSS 3.1MEDIUM 6.5
- TI-2024-02189 Dreamer CMS toEdit cross-site request forgery CVSS 3.1MEDIUM 6.5
- TI-2023-23528 Dreamer CMS v4.1.3 was discovered to contain a stored cross-site scripting (XSS)… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-3311 · CVE Program
- CVE-2024-3311 · NVD
- FIRST EPSS
- GHSA-96rw-9jfw-gw2m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences