Qemu: sdhci: heap buffer overflow in sdhci_write_dataport()
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
A heap-based buffer overflow was found in the SDHCI device emulation of QEMU. The bug is triggered when both `s->data_count` and the size of `s->fifo_buffer` are set to 0x200, leading to an out-of-bound access. A malicious guest could use this flaw to crash the QEMU process on the host, resulting in a denial of service condition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | qemu | 1.5.0 to before 9.0.0 | 9.0.0 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 6 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 7 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 7 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 8 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 8 Advanced Virtualization | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 9 | — | — | Not affected | CNA |
- qemu Vendor— Affected 1.5.0 to before 9.0.0 Fixed in 9.0.0 Patch available CNA
- Red Hat Enterprise Linux 6 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 8 Advanced Virtualization VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | before 7.2.11; 8.0.0 to before 8.2.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:9.0.0:-:*:*:*:*:*:* | 9.0.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:9.0.0:rc0:*:*:*:*:*:* | 9.0.0 rc0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:9.0.0:rc1:*:*:*:*:*:* | 9.0.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:9.0.0:rc2:*:*:*:*:*:* | 9.0.0 rc2 | Vulnerable | QEMU |
| cpe:2.3:o:netapp:hci_compute_node:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions before 7.2.11; 8.0.0 to before 8.2.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:9.0.0:-:*:*:*:*:*:* Versions 9.0.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:9.0.0:rc0:*:*:*:*:*:* Versions 9.0.0 rc0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:9.0.0:rc1:*:*:*:*:*:* Versions 9.0.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:9.0.0:rc2:*:*:*:*:*:* Versions 9.0.0 rc2 Vulnerable ·QEMU
- cpe:2.3:o:netapp:hci_compute_node:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · CNA qemu Fixed in 9.0.0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 8 Advanced Virtualization
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3447
- 2026-10-03 Alias added: GHSA-mq5w-grf9-5rp9
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-3447 · CVE Program
- CVE-2024-3447 · NVD
- FIRST EPSS
- GHSA-mq5w-grf9-5rp9 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-3447 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences