The Post Grid < 7.5.0 - Editor+ Stored XSS via Grid Creation
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid WordPress plugin before 7.5.0 does not sanitise and escape some of its Grid settings, which could allow high privilege users such as Editor and above to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00311 24th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed The Post Grid (Unknown): 7.5.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | The Post Grid | before 7.5.0 | 7.5.0 | Patch available | CNA |
- The Post Grid VendorUnknown Affected before 7.5.0 Fixed in 7.5.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:radiustheme:the_post_grid:*:*:*:*:*:wordpress:*:* | before 7.5.0 | Vulnerable | RadiusTheme |
- cpe:2.3:a:radiustheme:the_post_grid:*:*:*:*:*:wordpress:*:* Versions before 7.5.0 Vulnerable ·RadiusTheme
Remediation
- Fix · CNA The Post Grid (Unknown) Fixed in 7.5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3635
- 2026-10-03 Alias added: GHSA-v46p-p3v7-38cg
References
More RadiusTheme The Post Grid vulnerabilities
- TI-2023-20822 WordPress The Post Grid Plugin <= 7.2.7 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-23197 WordPress The Post Grid Plugin <= 5.0.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-23608 WordPress The Post Grid plugin <= 7.7.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-01332 The Post Grid <= 7.7.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via section title tag CVSS 3.1MEDIUM 6.4
- TI-2024-06874 The Post Grid <= 7.7.11 - Authenticated (Contributor+) Information Disclosure CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-3635 · CVE Program
- CVE-2024-3635 · NVD
- FIRST EPSS
- GHSA-v46p-p3v7-38cg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences