Arbitrary code injection vulnerability in Keras framework < 2.13
Priority MEDIUM 52CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A arbitrary code injection vulnerability in TensorFlow's Keras framework (<2.13) allows attackers to execute arbitrary code with the same permissions as the application using a model that allow arbitrary code irrespective of the application.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01745 77th percentileScored 2026-11-07
Fix Fixed keras (tensorflow): 2.13keras (PyPI): 2.13.1rc0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| keras | before 2.13 | 2.13 | Patch available | CNA | |
| — | keras (PyPI) | before 2.13.1rc0 | 2.13.1rc0 | Patch available | GHSA-x4wf-678h-2pmq |
- keras VendorGoogle Affected before 2.13 Fixed in 2.13 Patch available CNA
- keras (PyPI) Vendor— Affected before 2.13.1rc0 Fixed in 2.13.1rc0 Patch available GHSA-x4wf-678h-2pmq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keras:keras:*:*:*:*:*:*:*:* | before 2.13.1 | Vulnerable | keras-team |
- cpe:2.3:a:keras:keras:*:*:*:*:*:*:*:* Versions before 2.13.1 Vulnerable ·keras-team
Remediation
- Fix · CNA keras (tensorflow) Fixed in 2.13
- Fix · GHSA-x4wf-678h-2pmq keras (PyPI) Fixed in 2.13.1rc0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3660
- 2026-10-03 Alias added: GHSA-x4wf-678h-2pmq
References
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2024-3660 · CVE Program
- CVE-2024-3660 · NVD
- FIRST EPSS
- GHSA-x4wf-678h-2pmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences