Inefficient Regular Expression Complexity in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-1333.
Summary
A Denial of Service (DoS) condition has been discovered in GitLab CE/EE affecting all versions from 7.10 prior before 16.11.5, version 17.0 before 17.0.3, and 17.1 before 17.1.1. It is possible for an attacker to cause a denial of service using a crafted markdown page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 7.10 to before 16.11.5; 17.0 to before 17.0.3; 17.1 to before 17.1.1 | 16.11.5, 17.0.3, 17.1.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 7.10 to before 16.11.5; 17.0 to before 17.0.3; 17.1 to before 17.1.1 Fixed in 16.11.5, 17.0.3, 17.1.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 7.10.0 to before 16.11.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 7.10.0 to before 16.11.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.0.0 to before 17.0.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.0.0 to before 17.0.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:community:*:*:* | 17.1.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:enterprise:*:*:* | 17.1.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 7.10.0 to before 16.11.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 7.10.0 to before 16.11.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.0.0 to before 17.0.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.0.0 to before 17.0.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:community:*:*:* Versions 17.1.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:enterprise:*:*:* Versions 17.1.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.11.5, 17.0.3, 17.1.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.11.5, 17.0.3, 17.1.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-04638 Cross-Site Request Forgery (CSRF) in GitLabPriority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4025
- 2026-10-03 Alias added: GHSA-6w53-65xx-mgj9
References
Exploit 1
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-4025 · CVE Program
- CVE-2024-4025 · NVD
- FIRST EPSS
- GHSA-6w53-65xx-mgj9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences