Read the docs
TI-2024-03796 Aliases CVE-2024-4076GHSA-gfw8-mh94-9w58

Assertion failure when serving both stale cache data and authoritative zone content

Priority MEDIUM 43CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 16 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.

Summary

Client queries that trigger serving stale data and that also require lookups in local authoritative zone data may result in an assertion failure. This issue affects BIND 9 versions 9.16.13 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.11.33-S1 through 9.11.37-S1, 9.16.13-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.27-S1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02111 81st percentileScored 2026-11-07
Fix Partial Red Hat: 10 advisoriesRed Hat: 16 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.16.13 – 9.16.50; 9.18.0 – 9.18.27; 9.19.0 – 9.19.24; 9.11.33-S1 – 9.11.37-S1; 9.16.13-S1 – 9.16.50-S1; 9.18.11-S1 – 9.18.27-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.16.13 – 9.16.50; 9.18.0 – 9.18.27; 9.19.0 – 9.19.24; 9.11.33-S1 – 9.11.37-S1; 9.16.13-S1 – 9.16.50-S1; 9.18.11-S1 – 9.18.27-S1 Fixed in — No fix listed CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*——ISC
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions — — ·ISC

Remediation

Red Hat 10 advisories

  • RHSA-2024:6406 Released 2024-09-11 · Red Hat rating Important
    OpenShift Container Platform 4.14.36 security update
    • Red Hat OpenShift Container Platform 4.14 openshift4/cloud-network-config-controller-rhel8, openshift4/driver-toolkit-rhel9, openshift4/egress-router-cni-rhel8 +47
  • RHSA-2024:6013 Released 2024-09-05 · Red Hat rating Important
    OpenShift Container Platform 4.15.30 bug fix and security update
    • Red Hat OpenShift Container Platform 4.15 openshift4/ose-console, rhcos
  • RHSA-2024:6009 Released 2024-09-04 · Red Hat rating Important
    OpenShift Container Platform 4.13.49 bug fix and security update
    • Red Hat OpenShift Container Platform 4.13 openshift4/ose-coredns, openshift4/ose-installer, openshift4/ose-oauth-apiserver-rhel8 +1
Show 7 more Red Hat advisories
  • RHSA-2024:6004 Released 2024-09-03 · Red Hat rating Important
    OpenShift Container Platform 4.16.10 bug fix and security update
    • Red Hat OpenShift Container Platform 4.16 openshift4/ose-cluster-baremetal-operator-rhel9, openshift4/ose-csi-driver-manila-rhel9, openshift4/ose-hypershift-rhel9 +2
  • RHSA-2024:5907 Released 2024-08-27 · Red Hat rating Important
    bind and bind-dyndb-ldap security update
    • Red Hat Enterprise Linux AppStream E4S (v.9.0) bind-32:9.16.23-1.el9_0.7, bind-chroot-32:9.16.23-1.el9_0.7, bind-dnssec-doc-32:9.16.23-1.el9_0.7 +6
  • RHSA-2024:5813 Released 2024-08-26 · Red Hat rating Important
    bind and bind-dyndb-ldap security update
    • Red Hat CodeReady Linux Builder EUS (v.9.2) bind-devel-32:9.16.23-11.el9_2.5, bind-doc-32:9.16.23-11.el9_2.5, bind-libs-32:9.16.23-11.el9_2.5
    • Red Hat Enterprise Linux AppStream EUS (v.9.2) bind-32:9.16.23-11.el9_2.5, bind-chroot-32:9.16.23-11.el9_2.5, bind-dnssec-doc-32:9.16.23-11.el9_2.5 +6
  • RHSA-2024:5525 Released 2024-08-19 · Red Hat rating Important
    bind9.16 security update
    • Red Hat CodeReady Linux Builder EUS (v.8.8) bind9.16-devel-32:9.16.23-0.14.el8_8.5, bind9.16-doc-32:9.16.23-0.14.el8_8.5, bind9.16-libs-32:9.16.23-0.14.el8_8.5
    • Red Hat Enterprise Linux AppStream EUS (v.8.8) bind9.16-32:9.16.23-0.14.el8_8.5, bind9.16-chroot-32:9.16.23-0.14.el8_8.5, bind9.16-dnssec-utils-32:9.16.23-0.14.el8_8.5 +4
  • RHSA-2024:5231 Released 2024-08-15 · Red Hat rating Important
    bind and bind-dyndb-ldap security update
    • Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-18.el9_4.6, bind-chroot-32:9.16.23-18.el9_4.6, bind-dnssec-doc-32:9.16.23-18.el9_4.6 +6
    • Red Hat Enterprise Linux CRB (v. 9) bind-devel-32:9.16.23-18.el9_4.6, bind-doc-32:9.16.23-18.el9_4.6, bind-libs-32:9.16.23-18.el9_4.6
  • RHSA-2024:5418 Released 2024-08-15 · Red Hat rating Important
    bind9.16 security update
    • Red Hat Enterprise Linux AppStream AUS (v.8.6) bind9.16-32:9.16.23-0.7.el8_6.6, bind9.16-chroot-32:9.16.23-0.7.el8_6.6, bind9.16-libs-32:9.16.23-0.7.el8_6.6 +2
    • Red Hat Enterprise Linux AppStream E4S (v.8.6) bind9.16-32:9.16.23-0.7.el8_6.6, bind9.16-chroot-32:9.16.23-0.7.el8_6.6, bind9.16-libs-32:9.16.23-0.7.el8_6.6 +2
    • Red Hat Enterprise Linux AppStream TUS (v.8.6) bind9.16-32:9.16.23-0.7.el8_6.6, bind9.16-chroot-32:9.16.23-0.7.el8_6.6, bind9.16-libs-32:9.16.23-0.7.el8_6.6 +2
  • RHSA-2024:5390 Released 2024-08-14 · Red Hat rating Important
    bind9.16 security update
    • Red Hat Enterprise Linux AppStream (v. 8) bind9.16-32:9.16.23-0.22.el8_10, bind9.16-chroot-32:9.16.23-0.22.el8_10, bind9.16-dnssec-utils-32:9.16.23-0.22.el8_10 +4
    • Red Hat Enterprise Linux CRB (v. 8) bind9.16-devel-32:9.16.23-0.22.el8_10, bind9.16-doc-32:9.16.23-0.22.el8_10, bind9.16-libs-32:9.16.23-0.22.el8_10

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet
Red Hat OpenShift Container Platform 4AffectedNo fix yet
Red Hat CodeReady Linux Builder EUS (v.8.8)Fixed RHSA-2024:5525
Red Hat CodeReady Linux Builder EUS (v.9.2)Fixed RHSA-2024:5813
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2024:5390
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2024:5231
Red Hat Enterprise Linux AppStream AUS (v.8.6)Fixed RHSA-2024:5418
Red Hat Enterprise Linux AppStream E4S (v.8.6)Fixed RHSA-2024:5418
Red Hat Enterprise Linux AppStream E4S (v.9.0)Fixed RHSA-2024:5907
Red Hat Enterprise Linux AppStream EUS (v.8.8)Fixed RHSA-2024:5525
Red Hat Enterprise Linux AppStream EUS (v.9.2)Fixed RHSA-2024:5813
Red Hat Enterprise Linux AppStream TUS (v.8.6)Fixed RHSA-2024:5418
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2024:5390
Red Hat Enterprise Linux CRB (v. 9)Fixed RHSA-2024:5231
Red Hat OpenShift Container Platform 4.13Fixed RHSA-2024:6009
Red Hat OpenShift Container Platform 4.14Fixed RHSA-2024:6406
Red Hat OpenShift Container Platform 4.15Fixed RHSA-2024:6013
Red Hat OpenShift Container Platform 4.16Fixed RHSA-2024:6004
Not affected: 8 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4.13
  • Red Hat OpenShift Container Platform 4.14
  • Red Hat OpenShift Container Platform 4.15
  • Red Hat OpenShift Container Platform 4.16

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4076
  2. 2026-10-03 Alias added: GHSA-gfw8-mh94-9w58

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
See all 285 →

Sources