Apryse WebViewer PDF Document cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in Apryse WebViewer up to 10.8.0. It has been classified as problematic. This affects an unknown part of the component PDF Document Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.9 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-262419. NOTE: The vendor was contacted early about this disclosure and explains that the documentation recommends a strict Content Security Policy and the issue was fixed in release 10.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4327
- 2026-10-03 Alias added: GHSA-g666-fcvg-24h3
References
More Apryse vulnerabilities
- TI-2025-35383 An issue was discovered in the InsertFromURL() function of the Apryse HTML2PDF SDK thru… CVSS 3.1CRITICAL 9.8
- TI-2025-35382 A Local File Inclusion (LFI) and a Server-Side Request Forgery (SSRF) vulnerability was… CVSS 3.1HIGH 7.5
- TI-2023-05782 Apryse iText Reference Table PdfDocument.java memory leak CVSS 3.1MEDIUM 6.5
- TI-2023-05781 Apryse iText PdfDocument.java main array index CVSS 3.1MEDIUM 6.5
- TI-2024-37840 A Cross-Site Scripting (XSS) vulnerability in the Rendering Engine component in Apryse… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-4327 · CVE Program
- CVE-2024-4327 · NVD
- FIRST EPSS
- GHSA-g666-fcvg-24h3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences