WP Prayer II <= 2.4.7 - Email Settings Update via CSRF
Priority MEDIUM 60CWE-352Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The WP Prayer II WordPress plugin through 2.4.7 does not have CSRF check in place when updating its email settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00197 9th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Prayer II | up to 2.4.7 | — | No fix listed | CNA |
- WP Prayer II VendorUnknown Affected up to 2.4.7 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4480
- 2026-10-03 Alias added: GHSA-mgqc-jwxc-fx8x
References
More Go Prayer Prayer vulnerabilities
- TI-2024-04424 WP Prayer II <= 2.4.7 - Settings Update via CSRF CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-4480 · CVE Program
- CVE-2024-4480 · NVD
- FIRST EPSS
- GHSA-mgqc-jwxc-fx8x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences