Read the docs
TI-2024-04278 Aliases CVE-2024-4596GHSA-6f3v-2r2j-2rpr

Kimai Session information disclosure

Priority LOW 30CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

A vulnerability was found in Kimai up to 2.15.0 and classified as problematic. Affected by this issue is some unknown functionality of the component Session Handler. The manipulation of the argument PHPSESSIONID leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.16.0 is able to address this issue. It is recommended to upgrade the affected component. VDB-263318 is the identifier assigned to this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0079 56th percentileScored 2026-11-07
Fix Fixed kimai/kimai (Packagist): 2.16.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Kimai2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14; 2.15—No fix listedCNA
—kimai/kimai (Packagist)before 2.16.02.16.0Patch availableGHSA-6f3v-2r2j-2rpr
  • Kimai Vendor— Affected 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14; 2.15 Fixed in — No fix listed CNA
  • kimai/kimai (Packagist) Vendor— Affected before 2.16.0 Fixed in 2.16.0 Patch available GHSA-6f3v-2r2j-2rpr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kimai:kimai:*:*:*:*:*:*:*:*before 2.16.0Vulnerablekimai
  • cpe:2.3:a:kimai:kimai:*:*:*:*:*:*:*:* Versions before 2.16.0 Vulnerable ·kimai

Remediation

  • Fix · GHSA-6f3v-2r2j-2rpr kimai/kimai (Packagist) Fixed in 2.16.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4596
  2. 2026-10-03 Alias added: GHSA-6f3v-2r2j-2rpr

References

  • TI-2023-30240 Kimai 1.30.10 SameSite Cookie Vulnerability Session Hijacking CVSS 4.0HIGH 8.5
  • TI-2026-22900 Kimai: API invoice endpoint missing customer-level access control (IDOR) CVSS 3.1MEDIUM 6.5
  • TI-2026-30580 Kimai: Formula Injection via tag names in XLSX export CVSS 4.0MEDIUM 5.4
  • TI-2026-29230 Kimai: Stored XSS via Incomplete HTML Attribute Escaping in Team Member Widget CVSS 3.1MEDIUM 5.4
  • TI-2019-15371 Kimai 2- persistent cross-site scripting (XSS) CVSS 4.0MEDIUM 5.1
  • TI-2026-29237 Kimai's User Preferences API allows standard users to modify restricted attributes: hourly_rate, internal_rate CVSS 3.1MEDIUM 4.3
See all 13 →

Sources