Read the docs
TI-2024-04339 Aliases CVE-2024-4664GHSA-fg8w-72jj-fqx9

WP Chat App < 3.6.5 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Chat App WordPress plugin before 3.6.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admins to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00373 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Chat App (Unknown): 3.6.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Chat Appbefore 3.6.53.6.5Patch availableCNA
  • WP Chat App VendorUnknown Affected before 3.6.5 Fixed in 3.6.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ninjateam:wp_chat_app:*:*:*:*:*:wordpress:*:*before 3.6.5Vulnerableninjateam
  • cpe:2.3:a:ninjateam:wp_chat_app:*:*:*:*:*:wordpress:*:* Versions before 3.6.5 Vulnerable ·ninjateam

Remediation

  • Fix · CNA WP Chat App (Unknown) Fixed in 3.6.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4664
  2. 2026-10-03 Alias added: GHSA-fg8w-72jj-fqx9

References

  • TI-2024-02647 WP Chat App < 3.6.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-01638 WP Chat App <= 3.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes CVSS 3.1MEDIUM 6.4
  • TI-2024-02336 WP Chat App <= 3.6.2 - Authenticated(Contributor+) Stored Cross-Site Scripting via Block Image Attribute CVSS 3.1MEDIUM 6.4
  • TI-2023-28028 WordPress WP Chat App Plugin <= 3.4.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2024-09757 WP Chat App <= 3.6.8 - Missing Authorization to Authenticated (Subscriber+) Filebird Plugin Installation CVSS 3.1MEDIUM 4.3

Sources