Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A XSS condition exists within GitLab in versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this condition, an attacker can craft a malicious page to exfiltrate sensitive user information.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.11 to before 16.10.6; 16.11 to before 16.11.3; 17.0 to before 17.0.1 | 16.10.6, 16.11.3, 17.0.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.11 to before 16.10.6; 16.11 to before 16.11.3; 17.0 to before 17.0.1 Fixed in 16.10.6, 16.11.3, 17.0.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.11.0 to before 16.10.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.11.0 to before 16.10.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.11.0 to before 16.11.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.11.0 to before 16.11.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.0.0:*:*:*:community:*:*:* | 17.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.0.0:*:*:*:enterprise:*:*:* | 17.0.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.11.0 to before 16.10.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.11.0 to before 16.10.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.11.0 to before 16.11.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.11.0 to before 16.11.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.0.0:*:*:*:community:*:*:* Versions 17.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.0.0:*:*:*:enterprise:*:*:* Versions 17.0.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.10.6, 16.11.3, 17.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.10.6, 16.11.3, 17.0.1
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2024-02683 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 30
- TI-2024-01813 Improper Handling of Highly Compressed Data (Data Amplification) in GitLabPriority LOW 29
- TI-2023-05959 Inefficient Regular Expression Complexity in GitLabPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4835
- 2026-10-03 Alias added: GHSA-9r4p-g7c7-2c4r
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-4835 · CVE Program
- CVE-2024-4835 · NVD
- FIRST EPSS
- GHSA-9r4p-g7c7-2c4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences