CM Popup Plugin for WordPress < 1.6.6 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The CM Popup Plugin for WordPress WordPress plugin before 1.6.6 does not sanitise and escape some of the campaign settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00349 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed CM Popup Plugin for WordPress (Unknown): 1.6.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | CM Popup Plugin for WordPress | before 1.6.6 | 1.6.6 | Patch available | CNA |
- CM Popup Plugin for WordPress VendorUnknown Affected before 1.6.6 Fixed in 1.6.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cminds:cm_popup:*:*:*:*:*:wordpress:*:* | before 1.6.6 | Vulnerable | CreativeMindsSolutions |
- cpe:2.3:a:cminds:cm_popup:*:*:*:*:*:wordpress:*:* Versions before 1.6.6 Vulnerable ·CreativeMindsSolutions
Remediation
- Fix · CNA CM Popup Plugin for WordPress (Unknown) Fixed in 1.6.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5004
- 2026-10-03 Alias added: GHSA-26hr-4x6c-5c7x
References
More CreativeMindsSolutions Cm Popup vulnerabilities
- TI-2024-05376 CM Pop-Up Banners for WordPress < 1.7.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-14564 WordPress CM Pop-Up banners Plugin <= 1.5.10 is vulnerable to SQL Injection CVSS 3.1HIGH 8.5
Sources
- CVE-2024-5004 · CVE Program
- CVE-2024-5004 · NVD
- FIRST EPSS
- GHSA-26hr-4x6c-5c7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences