Integer overflow in libvpx
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Partial Red Hat: 8 fixed, 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chromium | libvpx | before 1.14.1 | 1.14.1 | Patch available | CNA |
- libvpx VendorChromium Affected before 1.14.1 Fixed in 1.14.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webmproject:libvpx:*:*:*:*:*:*:*:* | before 1.14.1 | Vulnerable | Webmproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:webmproject:libvpx:*:*:*:*:*:*:*:* Versions before 1.14.1 Vulnerable ·Webmproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA libvpx (Chromium) Fixed in 1.14.1
Red Hat 5 advisories
- RHSA-2025:14140 Released 2025-08-20 · Red Hat rating Moderatelibvpx security update
- Red Hat CodeReady Linux Builder EUS (v.9.4) libvpx-devel-1.9.0-7.el9_4.2
- Red Hat Enterprise Linux AppStream EUS (v.9.4) libvpx-1.9.0-7.el9_4.2
- RHSA-2025:14138 Released 2025-08-20 · Red Hat rating Moderatelibvpx security update
- Red Hat Enterprise Linux AppStream E4S (v.9.2) libvpx-1.9.0-7.el9_2.2
- RHSA-2025:14139 Released 2025-08-20 · Red Hat rating Moderatelibvpx security update
- Red Hat Enterprise Linux AppStream E4S (v.9.0) libvpx-1.9.0-7.el9_0.2
Show 2 more Red Hat advisories
- RHSA-2024:9827 Released 2024-11-18 · Red Hat rating Moderatelibvpx security update
- Red Hat CodeReady Linux Builder (v. 9) libvpx-devel-1.9.0-8.el9_5
- Red Hat Enterprise Linux AppStream (v. 9) libvpx-1.9.0-8.el9_5
- RHSA-2024:5941 Released 2024-08-28 · Red Hat rating Moderatelibvpx security update
- Red Hat Enterprise Linux AppStream (v. 8) libvpx-1.7.0-11.el8_10
- Red Hat Enterprise Linux CRB (v. 8) libvpx-devel-1.7.0-11.el8_10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2024:9827 |
| Red Hat CodeReady Linux Builder EUS (v.9.4) | Fixed | RHSA-2025:14140 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:5941 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:9827 |
| Red Hat Enterprise Linux AppStream E4S (v.9.0) | Fixed | RHSA-2025:14139 |
| Red Hat Enterprise Linux AppStream E4S (v.9.2) | Fixed | RHSA-2025:14138 |
| Red Hat Enterprise Linux AppStream EUS (v.9.4) | Fixed | RHSA-2025:14140 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2024:5941 |
Not affected: 1 product
- Red Hat Enterprise Linux 10
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5197
- 2026-10-03 Alias added: GHSA-4h58-f788-v8pw
References
More Chromium vulnerabilities
- TI-2023-01445 Use after free in Google Chrome CVSS 3.1HIGH 8.8
- TI-2017-04706 Memory corruption in Apple SQLite CVSS 3.0HIGH 8.8
- TI-2015-01084 Multiple unspecified vulnerabilities in Google Chrome before 40.0.2214.91 allow attackers… CVSS 2.0HIGH 7.5
- TI-2014-06607 The Fonts implementation in Google Chrome before 40.0.2214.91 does not initialize memory… CVSS 2.0HIGH 7.5
- TI-2023-01881 Use after free in libwebp CVSS 3.1HIGH 7.5
- TI-2015-01225 Multiple unspecified vulnerabilities in Google V8 before 3.30.33.15, as used in Google… CVSS 2.0HIGH 7.5
Sources
- CVE-2024-5197 · CVE Program
- CVE-2024-5197 · NVD
- FIRST EPSS
- GHSA-4h58-f788-v8pw · GitHub Advisory Database · CC BY 4.0
- CVE-2024-5197 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences