Bug Library < 2.1.2 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Bug Library WordPress plugin before 2.1.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00369 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Bug Library (Unknown): 2.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Bug Library | before 2.1.2 | 2.1.2 | Patch available | CNA |
- Bug Library VendorUnknown Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bug_library_project:bug_library:*:*:*:*:*:wordpress:*:* | before 2.1.2 | Vulnerable | Bug Library Project |
- cpe:2.3:a:bug_library_project:bug_library:*:*:*:*:*:wordpress:*:* Versions before 2.1.2 Vulnerable ·Bug Library Project
Remediation
- Fix · CNA Bug Library (Unknown) Fixed in 2.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5604
- 2026-10-03 Alias added: GHSA-xfx6-r52c-8v32
References
More Bug Library Project Bug Library vulnerabilities
- TI-2024-05065 Bug Library < 2.1.1 - Unauthenticated RCE CVSS 3.1CRITICAL 9.1
- TI-2021-15962 Bug Library <= 2.0.3 Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-5604 · CVE Program
- CVE-2024-5604 · NVD
- FIRST EPSS
- GHSA-xfx6-r52c-8v32 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences