CSRF Vulnerability in mudler/LocalAI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
A Cross-Site Request Forgery (CSRF) vulnerability exists in mudler/LocalAI versions up to and including 2.15.0, which allows attackers to trick victims into deleting installed models. By crafting a malicious HTML page, an attacker can cause the deletion of a model, such as 'gpt-4-vision-preview', without the victim's consent. The vulnerability is due to insufficient CSRF protection mechanisms on the model deletion functionality.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA mudler/localai (mudler) Fixed in 2.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
mudler/localai 2.17
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2024-05648 SSRF and Partial LFI in /models/apply Endpoint in mudler/localaiPriority HIGH 65
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5616
- 2026-10-03 Alias added: GHSA-chxg-pjh8-j2r6
References
More mudler Localai vulnerabilities
- TI-2024-04809 Command Injection in mudler/localai CVSS 3.0CRITICAL 9.8
- TI-2024-01889 Command Injection in mudler/localai CVSS 3.0CRITICAL 9.8
- TI-2024-04810 Path Traversal in mudler/localai CVSS 3.1CRITICAL 9.1
- TI-2024-06369 Arbitrary File Write in mudler/LocalAI CVSS 3.1CRITICAL 9.8
- TI-2024-06481 Remote Code Execution in mudler/localai CVSS 3.0HIGH 8.8
- TI-2024-06505 Timing Attack in mudler/localai CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-5616 · CVE Program
- CVE-2024-5616 · NVD
- FIRST EPSS
- GHSA-chxg-pjh8-j2r6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences