Insert or Embed Articulate Content into WordPress < 4.3000000024 - Author+ Arbitrary File Upload
Priority HIGH 73CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-434.
Summary
The Insert or Embed Articulate Content into WordPress plugin before 4.3000000024 does not prevent authors from uploading arbitrary files to the site, which may allow them to upload PHP shells on affected sites.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00675 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Insert or Embed Articulate Content into WordPress (Unknown): 4.3000000024
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Insert or Embed Articulate Content into WordPress | before 4.3000000024 | 4.3000000024 | Patch available | CNA |
- Insert or Embed Articulate Content into WordPress VendorUnknown Affected before 4.3000000024 Fixed in 4.3000000024 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elearningfreak:insert_or_embed_articulate_content:*:*:*:*:*:wordpress:*:* | before 4.3000000024 | Vulnerable | Elearningfreak |
- cpe:2.3:a:elearningfreak:insert_or_embed_articulate_content:*:*:*:*:*:wordpress:*:* Versions before 4.3000000024 Vulnerable ·Elearningfreak
Remediation
- Fix · CNA Insert or Embed Articulate Content into WordPress (Unknown) Fixed in 4.3000000024
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5630
- 2026-10-03 Alias added: GHSA-5m9v-g6cg-987g
References
More Elearningfreak Insert Or Embed Articulate Content vulnerabilities
- TI-2019-11744 The insert-or-embed-articulate-content-into-wordpress plugin before 4.2999 for WordPress… CVSS 3.0HIGH 8.8
- TI-2019-11743 The insert-or-embed-articulate-content-into-wordpress plugin before 4.29991 for WordPress… CVSS 3.0MEDIUM 6.5
- TI-2023-27729 Cross-site scripting in Brian Batt Insert or Embed Articulate Content into WordPress CVSS 3.1MEDIUM 6.5
- TI-2024-00697 Insert or Embed Articulate Content into WordPress <= 4.3000000023 - Author+ Upload to RCE CVSS 3.1MEDIUM 5.4
- TI-2024-00696 Insert or Embed Articulate Content into WordPress <= 4.3000000023 - Iframe Injection CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-5630 · CVE Program
- CVE-2024-5630 · NVD
- FIRST EPSS
- GHSA-5m9v-g6cg-987g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences