Reflected Cross-Site Scripting (XSS) in Multiple WSO2 Products Due to Improper Input Validation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A reflected cross-site scripting (XSS) vulnerability exists in multiple WSO2 products due to improper input validation. User-supplied data is directly included in server responses from vulnerable service endpoints without proper sanitization or encoding, allowing an attacker to inject malicious JavaScript. Successful exploitation could lead to UI manipulation, redirection to malicious websites, or data exfiltration from the browser. While session-related sensitive cookies are protected with the httpOnly flag, mitigating session hijacking risks, the impact may vary depending on gateway-level service restrictions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 3.1.0 to before 3.1.0.285; 3.2.0 to before 3.2.0.375; 3.2.1 to before 3.2.1.10; 4.0.0 to before 4.0.0.300; 4.1.0 to before 4.1.0.160; 4.2.0 to before 4.2.0.92; 4.3.0 to before 4.3.0.10 | 3.1.0.285, 3.2.0.375, 3.2.1.10, 4.0.0.300, 4.1.0.160, 4.2.0.92, 4.3.0.10 | Patch available | CNA |
| WSO2 | WSO2 Open Banking AM | 2.0.0 to before 2.0.0.349 | 2.0.0.349 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 3.1.0 to before 3.1.0.285; 3.2.0 to before 3.2.0.375; 3.2.1 to before 3.2.1.10; 4.0.0 to before 4.0.0.300; 4.1.0 to before 4.1.0.160; 4.2.0 to before 4.2.0.92; 4.3.0 to before 4.3.0.10 Fixed in 3.1.0.285, 3.2.0.375, 3.2.1.10, 4.0.0.300, 4.1.0.160, 4.2.0.92, 4.3.0.10 Patch available CNA
- WSO2 Open Banking AM VendorWSO2 Affected 2.0.0 to before 2.0.0.349 Fixed in 2.0.0.349 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.1.0.285, 3.2.0.375, 3.2.1.10, 4.0.0.300, 4.1.0.160, 4.2.0.92, 4.3.0.10
- Fix · CNA WSO2 Open Banking AM (WSO2) Fixed in 2.0.0.349
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5848
- 2026-10-03 Alias added: GHSA-4fqp-f52h-wwp8
References
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2024-5848 · CVE Program
- CVE-2024-5848 · NVD
- FIRST EPSS
- GHSA-4fqp-f52h-wwp8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences