Reflected Cross-Site Scripting (XSS) in Authentication Endpoint of Multiple WSO2 Products Due to Missing Output Encoding
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A reflected cross-site scripting (XSS) vulnerability exists in the authentication endpoint of multiple WSO2 products due to missing output encoding of user-supplied input. A malicious actor can exploit this vulnerability to inject arbitrary JavaScript into the authentication flow, potentially leading to UI modifications, redirections to malicious websites, or data exfiltration from the browser. While this issue could allow an attacker to manipulate the user’s browser, session-related sensitive cookies remain protected with the httpOnly flag, preventing session hijacking.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 4.2.0 to before 4.2.0.94; 4.3.0 to before 4.3.0.9 | 4.2.0.94, 4.3.0.9 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 6.0.0 to before 6.0.0.199; 6.1.0 to before 6.1.0.172 | 6.0.0.199, 6.1.0.172 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 4.2.0 to before 4.2.0.94; 4.3.0 to before 4.3.0.9 Fixed in 4.2.0.94, 4.3.0.9 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 6.0.0 to before 6.0.0.199; 6.1.0 to before 6.1.0.172 Fixed in 6.0.0.199, 6.1.0.172 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:6.0.0:-:*:*:*:*:*:* | 6.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:6.1.0:-:*:*:*:*:*:* | 6.1.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:6.0.0:-:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:6.1.0:-:*:*:*:*:*:* Versions 6.1.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 4.2.0.94, 4.3.0.9
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 6.0.0.199, 6.1.0.172
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5962
- 2026-10-03 Alias added: GHSA-mv2f-363v-qmfc
References
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2024-5962 · CVE Program
- CVE-2024-5962 · NVD
- FIRST EPSS
- GHSA-mv2f-363v-qmfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences