Read the docs
TI-2024-05559 Aliases CVE-2024-6000GHSA-339j-wg47-93c6

FooEvents for WooCommerce <= 1.19.20 - Improper Authorization to (Contributor+) Arbitrary File Upload

Priority LOW 34CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.

Summary

The FooEvents for WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary file uploads due to an improper capability setting on the 'display_ticket_themes_page' function in versions up to, and including, 1.19.20. This makes it possible for authenticated attackers with contributor-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in 1.19.20, and fully patched in 1.19.21.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00506 43rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FooEventsFooEvents for WooCommerceup to 1.19.20—No fix listedCNA
  • FooEvents for WooCommerce VendorFooEvents Affected up to 1.19.20 Fixed in — No fix listed CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:fooevents:fooevents:1.19.20:*:*:*:*:*:*:*1.19.20—FooEvents
  • cpe:2.3:a:fooevents:fooevents:1.19.20:*:*:*:*:*:*:* Versions 1.19.20 — ·FooEvents

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-6000
  2. 2026-10-03 Alias added: GHSA-339j-wg47-93c6

References

  • TI-2025-42500 WordPress FooEvents for WooCommerce plugin <= 1.20.4 - SQL Injection vulnerability CVSS 3.1HIGH 8.5

Sources