WP eStore < 8.5.6 - Reflected XSS in Product Editing
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The wp-cart-for-digital-products WordPress plugin before 8.5.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00401 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed wp-cart-for-digital-products (Unknown): 8.5.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | wp-cart-for-digital-products | before 8.5.6 | 8.5.6 | Patch available | CNA |
- wp-cart-for-digital-products VendorUnknown Affected before 8.5.6 Fixed in 8.5.6 Patch available CNA
Remediation
- Fix · CNA wp-cart-for-digital-products (Unknown) Fixed in 8.5.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6134
- 2026-10-03 Alias added: GHSA-5236-gxxf-m73h
References
More mra13 Wp Estore vulnerabilities
- TI-2024-05631 WP eStore < 8.5.5 - Coupon Deletion via CSRF CVSS 3.1HIGH 8.8
- TI-2024-05683 WP eStore < 8.5.6 - Reflected XSS in Customer Search CVSS 3.1MEDIUM 6.5
- TI-2024-05632 WP eStore < 8.5.5 - Reflected XSS in Category Editing CVSS 3.1MEDIUM 6.1
- TI-2024-05630 WP eStore < 8.5.5 - Reflected XSS in Customer Editing CVSS 3.1MEDIUM 6.1
- TI-2024-05629 WP eStore < 8.5.5 - Reflected XSS in Discount Editing CVSS 3.1MEDIUM 6.1
- TI-2024-05628 WP eStore < 8.5.5 - Reflected XSS via $_SERVER['REQUEST_URI'] CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-6134 · CVE Program
- CVE-2024-6134 · NVD
- FIRST EPSS
- GHSA-5236-gxxf-m73h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences