PayPlus Payment Gateway < 6.6.9 - Unauthenticated SQLi
Priority HIGH 76CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The PayPlus Payment Gateway WordPress plugin before 6.6.9 does not properly sanitise and escape a parameter before using it in a SQL statement via a WooCommerce API route available to unauthenticated users, leading to an SQL injection vulnerability.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.04134 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PayPlus Payment Gateway (Unknown): 6.6.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PayPlus Payment Gateway | before 6.6.9 | 6.6.9 | Patch available | CNA |
- PayPlus Payment Gateway VendorUnknown Affected before 6.6.9 Fixed in 6.6.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:payplus:payplus_payment_gateway:*:*:*:*:*:wordpress:*:* | before 6.6.9 | Vulnerable | PayPlus LTD |
- cpe:2.3:a:payplus:payplus_payment_gateway:*:*:*:*:*:wordpress:*:* Versions before 6.6.9 Vulnerable ·PayPlus LTD
Remediation
- Fix · CNA PayPlus Payment Gateway (Unknown) Fixed in 6.6.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6205
- 2026-10-03 Alias added: GHSA-h8w3-xwp6-m9v8
References
More PayPlus LTD Payplus Payment Gateway vulnerabilities
- TI-2024-24963 WordPress PayPlus Payment Gateway plugin <= 6.6.8 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-6205 · CVE Program
- CVE-2024-6205 · NVD
- FIRST EPSS
- GHSA-h8w3-xwp6-m9v8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences