Read the docs
TI-2024-05786 Aliases CVE-2024-6239GHSA-cc4h-7j78-49pj

Poppler: pdfinfo: crash in broken documents when using -dests parameter

Priority LOW 34CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 4 fixed, 4 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

A flaw was found in the Poppler's Pdfinfo utility. This issue occurs when using -dests parameter with pdfinfo utility. By using certain malformed input files, an attacker could cause the utility to crash, leading to a denial of service.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00785 56th percentileScored 2026-11-07
Fix Partial Red Hat: 2 advisoriesRed Hat: 4 fixed, 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—poppler24.06.0 – 24.06.1—No fix listedCNA
Red HatRed Hat Enterprise Linux 8—20.11.0-12.el8_10Patch availableCNA
Red HatRed Hat Enterprise Linux 9—21.01.0-21.el9Patch availableCNA
Red HatRed Hat Enterprise Linux 10——Not affectedCNA
Red HatRed Hat Enterprise Linux 6——No fix listedCNA
Red HatRed Hat Enterprise Linux 7——No fix listedCNA
Red HatRed Hat Enterprise Linux 7——No fix listedCNA
Red HatRed Hat Enterprise Linux 8——No fix listedCNA
Red HatRed Hat Enterprise Linux 8——No fix listedCNA
Red HatRed Hat Enterprise Linux 8——No fix listedCNA
Red HatRed Hat Enterprise Linux 9——No fix listedCNA
Red HatRed Hat Enterprise Linux 9——No fix listedCNA
  • poppler Vendor— Affected 24.06.0 – 24.06.1 Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in 20.11.0-12.el8_10 Patch available CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in 21.01.0-21.el9 Patch available CNA
  • Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 6 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — No fix listed CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:freedesktop:poppler:*:*:*:*:*:*:*:*before 24.06.0VulnerableFreedesktop
cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*7.0VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*8.0VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:*9.0VulnerableRed Hat
  • cpe:2.3:a:freedesktop:poppler:*:*:*:*:*:*:*:* Versions before 24.06.0 Vulnerable ·Freedesktop
  • cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Red Hat

Remediation

Red Hat 2 advisories

  • RHSA-2024:9167 Released 2024-11-12 · Red Hat rating Moderate
    poppler security update
    • Red Hat CodeReady Linux Builder (v. 9) poppler-cpp-devel-21.01.0-21.el9, poppler-devel-21.01.0-21.el9, poppler-glib-devel-21.01.0-21.el9 +2
    • Red Hat Enterprise Linux AppStream (v. 9) poppler-21.01.0-21.el9, poppler-cpp-21.01.0-21.el9, poppler-glib-21.01.0-21.el9 +2
  • RHSA-2024:5305 Released 2024-08-13 · Red Hat rating Moderate
    poppler security update
    • Red Hat Enterprise Linux AppStream (v. 8) poppler-20.11.0-12.el8_10, poppler-glib-20.11.0-12.el8_10, poppler-qt5-20.11.0-12.el8_10 +1
    • Red Hat Enterprise Linux CRB (v. 8) poppler-cpp-20.11.0-12.el8_10, poppler-cpp-devel-20.11.0-12.el8_10, poppler-devel-20.11.0-12.el8_10 +3

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 8AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 9AffectedNo fix yet
Red Hat CodeReady Linux Builder (v. 9)Fixed RHSA-2024:9167
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2024:5305
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2024:9167
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2024:5305
Not affected: 1 product
  • Red Hat Enterprise Linux 10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-6239
  2. 2026-10-03 Alias added: GHSA-cc4h-7j78-49pj

References

  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-10530 Code injection in [UNKNOWN] RichFaces KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-23530 Sudo before 1.9.17p1 allows local users to obtain root access because /etc/nsswitch.conf… KEVCVSS 3.1CRITICAL 9.3
  • TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
See all 1955 →

Sources