Content Spoofing in Multiple WSO2 Products via Error Message Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-451.
Summary
A content spoofing vulnerability exists in multiple WSO2 products due to improper error message handling. Under certain conditions, error messages are passed through URL parameters without validation, allowing malicious actors to inject arbitrary content into the UI. By exploiting this vulnerability, attackers can manipulate browser-displayed error messages, enabling social engineering attacks through deceptive or misleading content.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 Identity Server as Key Manager | 5.10.0 to before 5.10.0.338 | 5.10.0.338 | Patch available | CNA |
| WSO2 | WSO2 API Manager | 3.2.0 to before 3.2.0.409; 3.2.1 to before 3.2.1.33; 4.0.0 to before 4.0.0.327; 4.1.0 to before 4.1.0.188; 4.2.0 to before 4.2.0.128; 4.3.0 to before 4.3.0.38; 4.4.0 to before 4.4.0.4 | 3.2.0.409, 3.2.1.33, 4.0.0.327, 4.1.0.188, 4.2.0.128, 4.3.0.38, 4.4.0.4 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 5.10.0 to before 5.10.0.314; 5.11.0 to before 5.11.0.359; 6.0.0 to before 6.0.0.203; 6.1.0 to before 6.1.0.176; 7.0.0 to before 7.0.0.48 | 5.10.0.314, 5.11.0.359, 6.0.0.203, 6.1.0.176, 7.0.0.48 | Patch available | CNA |
| — | org.wso2.identity.apps:authentication-portal (Maven) | before 2.4.4 | 2.4.4 | Patch available | GHSA-r6f3-55wj-g9p3 |
- WSO2 Identity Server as Key Manager VendorWSO2 Affected 5.10.0 to before 5.10.0.338 Fixed in 5.10.0.338 Patch available CNA
- WSO2 API Manager VendorWSO2 Affected 3.2.0 to before 3.2.0.409; 3.2.1 to before 3.2.1.33; 4.0.0 to before 4.0.0.327; 4.1.0 to before 4.1.0.188; 4.2.0 to before 4.2.0.128; 4.3.0 to before 4.3.0.38; 4.4.0 to before 4.4.0.4 Fixed in 3.2.0.409, 3.2.1.33, 4.0.0.327, 4.1.0.188, 4.2.0.128, 4.3.0.38, 4.4.0.4 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 5.10.0 to before 5.10.0.314; 5.11.0 to before 5.11.0.359; 6.0.0 to before 6.0.0.203; 6.1.0 to before 6.1.0.176; 7.0.0 to before 7.0.0.48 Fixed in 5.10.0.314, 5.11.0.359, 6.0.0.203, 6.1.0.176, 7.0.0.48 Patch available CNA
- org.wso2.identity.apps:authentication-portal (Maven) Vendor— Affected before 2.4.4 Fixed in 2.4.4 Patch available GHSA-r6f3-55wj-g9p3
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* | 4.4.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:* | 5.10.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:* | 5.11.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:* Versions 5.11.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 Identity Server as Key Manager (WSO2) Fixed in 5.10.0.338
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.2.0.409, 3.2.1.33, 4.0.0.327, 4.1.0.188, 4.2.0.128, 4.3.0.38, 4.4.0.4
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.10.0.314, 5.11.0.359, 6.0.0.203, 6.1.0.176, 7.0.0.48
- Fix · GHSA-r6f3-55wj-g9p3 org.wso2.identity.apps:authentication-portal (Maven) Fixed in 2.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6429
- 2026-10-03 Alias added: GHSA-r6f3-55wj-g9p3
References
Advisory 2
Other 5
- https://github.com/wso2/identity-apps/pull/6488
- https://github.com/wso2/identity-apps/commit/75babf6b60f940f86bada7020e5d464ca95e47f2
- https://github.com/wso2/identity-apps
- https://github.com/wso2/identity-apps/releases/tag/@wso2is/[email protected]
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2025/WSO2-2024-3490
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2024-6429 · CVE Program
- CVE-2024-6429 · NVD
- FIRST EPSS
- GHSA-r6f3-55wj-g9p3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences