CTT Expresso para WooCommerce < 3.2.13 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The CTT Expresso para WooCommerce WordPress plugin before 3.2.13 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed CTT Expresso para WooCommerce (Unknown): 3.2.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | CTT Expresso para WooCommerce | before 3.2.13 | 3.2.13 | Patch available | CNA |
- CTT Expresso para WooCommerce VendorUnknown Affected before 3.2.13 Fixed in 3.2.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thisfunctional:ctt_expresso_para_woocommerce:*:*:*:*:*:wordpress:*:* | before 3.2.13 | Vulnerable | this.functional |
- cpe:2.3:a:thisfunctional:ctt_expresso_para_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 3.2.13 Vulnerable ·this.functional
Remediation
- Fix · CNA CTT Expresso para WooCommerce (Unknown) Fixed in 3.2.13
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6478
- 2026-10-03 Alias added: GHSA-vf8r-rhw4-6q8g
References
More this.functional Ctt Expresso Para Woocommerce vulnerabilities
- TI-2024-06196 CTT Expresso para WooCommerce <= 3.2.12 - Information Exposure via Unprotected Directory CVSS 3.1HIGH 7.5
- TI-2022-23627 WordPress CTT Expresso para WooCommerce Plugin <= 3.2.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-6478 · CVE Program
- CVE-2024-6478 · NVD
- FIRST EPSS
- GHSA-vf8r-rhw4-6q8g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences