Path Traversal in AP Page Builder
Priority MEDIUM 45CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
Absolute Path Traversal vulnerability in AP Page Builder versions prior to 4.0.0 could allow an unauthenticated remote user to modify the 'product_item_path' within the 'config' JSON file, allowing them to read any file on the system.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00684 52nd percentileScored 2026-11-07
Fix Fixed AP Page Builder (Apollo Theme): 4.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apollo Theme | AP Page Builder | before 4.0.0 | 4.0.0 | Patch available | CNA |
- AP Page Builder VendorApollo Theme Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apollotheme:ap_pagebuilder:*:*:*:*:*:prestashop:*:* | before 4.0.0 | Vulnerable | Apollo Theme |
- cpe:2.3:a:apollotheme:ap_pagebuilder:*:*:*:*:*:prestashop:*:* Versions before 4.0.0 Vulnerable ·Apollo Theme
Remediation
- Fix · CNA AP Page Builder (Apollo Theme) Fixed in 4.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6648
- 2026-10-03 Alias added: GHSA-6m2f-83vf-p7fj
- 2026-10-04 EPSS moved to the 50th–90th percentile
References
More Apollo Theme Ap Pagebuilder vulnerabilities
- TI-2022-07099 A SQL injection vulnerability in the product_all_one_img and image_product parameters of… CVSS 3.1CRITICAL 9.8
- TI-2022-22083 A cross-site scripting (XSS) vulnerability in ApolloTheme AP PageBuilder component… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-6648 · CVE Program
- CVE-2024-6648 · NVD
- FIRST EPSS
- GHSA-6m2f-83vf-p7fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences