Generate Images – Magic Post Thumbnail < 5.2.8 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Generate Images WordPress plugin before 5.2.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00399 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Generate Images (Unknown): 5.2.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Generate Images | before 5.2.8 | 5.2.8 | Patch available | CNA |
- Generate Images VendorUnknown Affected before 5.2.8 Fixed in 5.2.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magic-post-thumbnail:magic_post_thumbnail:*:*:*:*:*:wordpress:*:* | before 5.2.8 | Vulnerable | Magic Post Thumbnail |
- cpe:2.3:a:magic-post-thumbnail:magic_post_thumbnail:*:*:*:*:*:wordpress:*:* Versions before 5.2.8 Vulnerable ·Magic Post Thumbnail
Remediation
- Fix · CNA Generate Images (Unknown) Fixed in 5.2.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6724
- 2026-10-03 Alias added: GHSA-ch8j-4g5p-qvwx
References
More Magic Post Thumbnail vulnerabilities
- TI-2024-29510 WordPress Generate Images – Magic Post Thumbnail plugin <= 5.2.9 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-13602 WordPress Magic Post Thumbnail Plugin <= 4.1.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
Sources
- CVE-2024-6724 · CVE Program
- CVE-2024-6724 · NVD
- FIRST EPSS
- GHSA-ch8j-4g5p-qvwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences