Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A cross site scripting vulnerability exists in GitLab CE/EE affecting all versions from 16.6 prior to 17.0.5, 17.1 prior to 17.1.3, 17.2 prior to 17.2.1 allowing an attacker to execute arbitrary scripts under the context of the current logged in user.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.6 to before 17.0.5; 17.1 to before 17.1.3; 17.2 to before 17.2.1 | 17.0.5, 17.1.3, 17.2.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.6 to before 17.0.5; 17.1 to before 17.1.3; 17.2 to before 17.2.1 Fixed in 17.0.5, 17.1.3, 17.2.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.6.0 to before 17.0.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.6.0 to before 17.0.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.1.0 to before 17.1.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.1.0 to before 17.1.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:7.2.0:*:*:*:community:*:*:* | 7.2.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:7.2.0:*:*:*:enterprise:*:*:* | 7.2.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.6.0 to before 17.0.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.6.0 to before 17.0.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.1.0 to before 17.1.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.1.0 to before 17.1.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:7.2.0:*:*:*:community:*:*:* Versions 7.2.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:7.2.0:*:*:*:enterprise:*:*:* Versions 7.2.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.0.5, 17.1.3, 17.2.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.0.5, 17.1.3, 17.2.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-06539 Improper Access Control in GitLabPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7047
- 2026-10-03 Alias added: GHSA-x8pf-46vx-rg97
References
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-7047 · CVE Program
- CVE-2024-7047 · NVD
- FIRST EPSS
- GHSA-x8pf-46vx-rg97 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences