FFmpeg pnmdec.c pnm_decode_frame heap-based overflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | FFmpeg | 7.0.0; 7.0.1 | — | No fix listed | CNA |
- FFmpeg Vendor— Affected 7.0.0; 7.0.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* | before 4.3.8; 4.4 to before 4.4.5; 5.0 to before 5.1.6; 6.0 to before 6.1.2; 7.0 to before 7.0.2 | Vulnerable | FFmpeg |
- cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* Versions before 4.3.8; 4.4 to before 4.4.5; 5.0 to before 5.1.6; 6.0 to before 6.1.2; 7.0 to before 7.0.2 Vulnerable ·FFmpeg
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7055
- 2026-10-03 Alias added: GHSA-5gxm-744m-qfgp
References
More Ffmpeg vulnerabilities
- TI-2025-19015 FFmpeg git-master before commit d5873b was discovered to contain a memory leak in the component libavutil/iamf.c. CVSS 3.1HIGH 8.8
- TI-2024-21238 FFmpeg 7.0 contains a heap-buffer-overflow at libavfilter/vf_tiltandshift.c:189:5 in copy_column. CVSS 3.1HIGH 8.4
- TI-2023-06050 Ffmpeg: null pointer dereference in ffmpeg hls parsing CVSS 3.1HIGH 7.5
- TI-2023-28420 Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to… CVSS 3.1HIGH 8.0
- TI-2023-27357 FFmpeg v.n6.1-3-g466799d4f5 allows a heap-based buffer overflow via the… CVSS 3.1HIGH 8.0
- TI-2023-27044 Buffer Overflow vulnerability in FFmpeg version n6.1-3-g466799d4f5, allows a local… CVSS 3.1HIGH 8.0
Sources
- CVE-2024-7055 · CVE Program
- CVE-2024-7055 · NVD
- FIRST EPSS
- GHSA-5gxm-744m-qfgp · GitHub Advisory Database · CC BY 4.0
- CVE-2024-7055 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences