WPForms < 1.9.1.6 - Admin+ Stored XSS
Priority LOW 17CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WPForms WordPress plugin before 1.9.1.6 does not sanitise and escape some of its settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00448 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WPForms (Unknown): 1.9.1.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPForms | before 1.9.1.6 | 1.9.1.6 | Patch available | CNA |
- WPForms VendorUnknown Affected before 1.9.1.6 Fixed in 1.9.1.6 Patch available CNA
Remediation
- Fix · CNA WPForms (Unknown) Fixed in 1.9.1.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7056
- 2026-10-03 Alias added: GHSA-8pvr-h3wm-pfpm
References
More Wpforms vulnerabilities
- TI-2020-19054 WPForms 1.7.8 - Cross-Site Scripting (XSS) CVSS 4.0MEDIUM 5.1
- TI-2024-10397 WPForms < 1.9.2.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.7
- TI-2024-37245 WordPress WPForms Lite plugin <= 1.9.2.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-10379 Missing authorization in smub WPForms – Easy Form Builder for WordPress – Contact Forms… CVSS 3.1HIGH 8.5
- TI-2023-06459 Cross-site scripting in WPForms Pro CVSS 3.1HIGH 7.2
- TI-2024-12445 WPForms Lite <= 1.9.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via fieldHTML Parameter CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-7056 · CVE Program
- CVE-2024-7056 · NVD
- FIRST EPSS
- GHSA-8pvr-h3wm-pfpm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences