Ninja Forms 3.8.6-3.8.10 - Reflected XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ninja Forms WordPress plugin before 3.8.11 does not escape an URL before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00702 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ninja Forms (Unknown): 3.8.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ninja Forms | 3.8.6 to before 3.8.11 | 3.8.11 | Patch available | CNA |
- Ninja Forms VendorUnknown Affected 3.8.6 to before 3.8.11 Fixed in 3.8.11 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ninjaforms:ninja_forms:*:*:*:*:*:wordpress:*:* | 3.8.6 to before 3.8.11 | Vulnerable | Saturday Drive |
- cpe:2.3:a:ninjaforms:ninja_forms:*:*:*:*:*:wordpress:*:* Versions 3.8.6 to before 3.8.11 Vulnerable ·Saturday Drive
Remediation
- Fix · CNA Ninja Forms (Unknown) Fixed in 3.8.11
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7354
- 2026-10-03 Alias added: GHSA-h3jv-jqj2-3j68
References
More Saturday Drive Ninja Forms vulnerabilities
- TI-2025-08325 Ninja-forms < 3.11.1 - Unauthenticated PHP Objection CVSS 3.1CRITICAL 9.8
- TI-2016-01107 The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct… CVSS 3.0CRITICAL 9.8
- TI-2023-19777 WordPress Ninja Forms plugin <= 3.6.25 - Subscriber+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-02691 NinjaForms < 3.6.13 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2023-01723 Ninja Forms < 3.6.22 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2025-02230 Ninja Forms < 3.10.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-7354 · CVE Program
- CVE-2024-7354 · NVD
- FIRST EPSS
- GHSA-h3jv-jqj2-3j68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences