Concrete CMS version 9.0.0 through 9.3.2 and below 8.5.18 - Stored XSS in getAttributeSetName()
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS versions 9 through 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in getAttributeSetName(). A rogue administrator could inject malicious code. The Concrete CMS team gave this a CVSS v4.0 rank of 4.6 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Thanks, m3dium for reporting. (CNA updated this risk rank on 20 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concrete5/concrete5 (Packagist) | before 8.5.18 | 8.5.18 | Patch available | GHSA-w6j6-w6jx-vf2r |
| — | concrete5/concrete5 (Packagist) | 9.0.0 to before 9.3.3 | 9.3.3 | Patch available | GHSA-w6j6-w6jx-vf2r |
- concrete5/concrete5 (Packagist) Vendor— Affected before 8.5.18 Fixed in 8.5.18 Patch available GHSA-w6j6-w6jx-vf2r
- concrete5/concrete5 (Packagist) Vendor— Affected 9.0.0 to before 9.3.3 Fixed in 9.3.3 Patch available GHSA-w6j6-w6jx-vf2r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 8.5.18; 9.0.0 to before 9.3.3 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 8.5.18; 9.0.0 to before 9.3.3 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-w6j6-w6jx-vf2r concrete5/concrete5 (Packagist) Fixed in 8.5.18 Advisory →
- Fix · GHSA-w6j6-w6jx-vf2r concrete5/concrete5 (Packagist) Fixed in 9.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7394
- 2026-10-03 Alias added: GHSA-w6j6-w6jx-vf2r
References
Patch 2
Advisory 3
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/933-release-notes?pk_vid=e367a434ef4830491723055753d52041
- https://documentation.concretecms.org/developers/introduction/version-history/8518-release-notes?pk_vid=e367a434ef4830491723055758d52041
- https://nvd.nist.gov/vuln/detail/CVE-2024-7394
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-7394 · CVE Program
- CVE-2024-7394 · NVD
- FIRST EPSS
- GHSA-w6j6-w6jx-vf2r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences