WordPress Comments Import & Export <= 2.3.7 - Authenticated (Author+) Arbitrary File Read via Directory Traversal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
The WordPress Comments Import & Export plugin for WordPress is vulnerable to to arbitrary file read due to insufficient file path validation during the comments import process, in versions up to, and including, 2.3.7. This makes it possible for authenticated attackers, with Author-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information. The issue was partially fixed in version 2.3.8 and fully fixed in 2.3.9
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7514
- 2026-10-03 Alias added: GHSA-xxrw-hw8c-v7g8
References
More WebToffee vulnerabilities
- TI-2024-07682 GDPR Cookie Consent <= 2.6.0 - Bulk Delete via CSRF CVSS 3.1MEDIUM 6.5
- TI-2024-07785 GDPR Cookie Consent <= 2.6.0 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-20216 WordPress Export and Import Users and Customers plugin <= 2.5.2 - Path Traversal vulnerability CVSS 3.1MEDIUM 4.3
- TI-2024-00649 Stripe Payment Plugin for WooCommerce <= 3.7.9 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-02962 Stripe Payment Plugin for WooCommerce <= 3.7.7 - Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2022-23148 WordPress Product Reviews Import Export for WooCommerce Plugin <= 1.4.8 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-7514 · CVE Program
- CVE-2024-7514 · NVD
- FIRST EPSS
- GHSA-xxrw-hw8c-v7g8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences