FastAdmin lang path traversal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
A vulnerability, which was classified as problematic, has been found in FastAdmin up to 1.3.3.20220121. Affected by this issue is some unknown functionality of the file /index/ajax/lang. The manipulation of the argument lang leads to path traversal. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.4.20220530 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | FastAdmin | 1.3.3.20220121 | — | No fix listed | CNA |
- FastAdmin Vendor— Affected 1.3.3.20220121 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7928
- 2026-10-03 Alias added: GHSA-gp9j-wjxg-4r78
References
More Fastadmin vulnerabilities
- TI-2025-13651 FastAdmin Backend Controller Backend.php selectpage sql injection CVSS 4.0MEDIUM 5.1
- TI-2024-06907 FastAdmin Attachment Management Section 4 cross site scripting CVSS 4.0MEDIUM 5.1
- TI-2021-19163 fastadmin v1.2.1 is affected by a file upload vulnerability which allows arbitrary code execution through shell access. CVSS 3.1CRITICAL 9.8
- TI-2020-15884 The member center function in fastadmin V1.0.0.20200506_beta is vulnerable to a… CVSS 3.1HIGH 8.8
- TI-2019-13017 An issue was discovered in fastadmin 1.0.0.20190705_beta. CVSS 3.1HIGH 8.8
- TI-2019-08284 FastAdmin V1.0.0.20190111_beta has a CSRF vulnerability to add a new admin user via the… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-7928 · CVE Program
- CVE-2024-7928 · NVD
- FIRST EPSS
- GHSA-gp9j-wjxg-4r78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences