CSFLE and Queryable Encryption self-lookup may fail to encrypt values in subpipelines
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-319.
Summary
A bug in query analysis of certain complex self-referential $lookup subpipelines may result in literal values in expressions for encrypted fields to be sent to the server as plaintext instead of ciphertext. Should this occur, no documents would be returned or written. This issue affects mongocryptd binary (v5.0 versions prior to 5.0.29, v6.0 versions prior to 6.0.17, v7.0 versions prior to 7.0.12 and v7.3 versions prior to 7.3.4) and mongo_crypt_v1.so shared libraries (v6.0 versions prior to 6.0.17, v7.0 versions prior to 7.0.12 and v7.3 versions prior to 7.3.4) released alongside MongoDB Enterprise Server versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | mongocryptd | 5.0 to before 5.0.29; 6.0 to before 6.0.17; 7.0 to before 7.012; 7.3 to before 7.3.4 | 5.0.29, 6.0.17, 7.012, 7.3.4 | Patch available | CNA |
| MongoDB | Mongo_crypt_v1.so | 6.0 to before 6.0.17; 7.0 to before 7.0.12; 7.3 to before 7.3.4 | 6.0.17, 7.0.12, 7.3.4 | Patch available | CNA |
- mongocryptd VendorMongoDB Affected 5.0 to before 5.0.29; 6.0 to before 6.0.17; 7.0 to before 7.012; 7.3 to before 7.3.4 Fixed in 5.0.29, 6.0.17, 7.012, 7.3.4 Patch available CNA
- Mongo_crypt_v1.so VendorMongoDB Affected 6.0 to before 6.0.17; 7.0 to before 7.0.12; 7.3 to before 7.3.4 Fixed in 6.0.17, 7.0.12, 7.3.4 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongo_crypt_v1.so:*:*:*:*:*:mongodb:*:* | 6.0.0 to before 6.0.17; 7.0.0 to before 7.0.12; 7.3.0 to before 7.3.4 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongocryptd:*:*:*:*:*:mongodb:*:* | 5.0.0 to before 5.0.29; 6.0.0 to before 6.0.17; 7.0.0 to before 7.0.12; 7.3.0 to before 7.3.4 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongo_crypt_v1.so:*:*:*:*:*:mongodb:*:* Versions 6.0.0 to before 6.0.17; 7.0.0 to before 7.0.12; 7.3.0 to before 7.3.4 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongocryptd:*:*:*:*:*:mongodb:*:* Versions 5.0.0 to before 5.0.29; 6.0.0 to before 6.0.17; 7.0.0 to before 7.0.12; 7.3.0 to before 7.3.4 Vulnerable ·MongoDB
Remediation
- Fix · CNA mongocryptd (MongoDB Inc) Fixed in 5.0.29, 6.0.17, 7.012, 7.3.4
- Fix · CNA Mongo_crypt_v1.so (MongoDB Inc) Fixed in 6.0.17, 7.0.12, 7.3.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8013
- 2026-10-03 Alias added: GHSA-mpw3-23h3-rhrx
References
Sources
- CVE-2024-8013 · CVE Program
- CVE-2024-8013 · NVD
- FIRST EPSS
- GHSA-mpw3-23h3-rhrx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences