Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 17.3.6, 17.4 before 17.4.3, and 17.5 before 17.5.1. An attacker could inject HTML into the Global Search field on a diff view leading to XSS.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.10 to before 17.3.6; 17.4 to before 17.4.3; 17.5 to before 17.5.1 | 17.3.6, 17.4.3, 17.5.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.10 to before 17.3.6; 17.4 to before 17.4.3; 17.5 to before 17.5.1 Fixed in 17.3.6, 17.4.3, 17.5.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.10.0 to before 17.3.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.10.0 to before 17.3.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.4.0 to before 17.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.4.0 to before 17.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:community:*:*:* | 17.5.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:enterprise:*:*:* | 17.5.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.10.0 to before 17.3.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.10.0 to before 17.3.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.4.0 to before 17.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.4.0 to before 17.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:community:*:*:* Versions 17.5.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:enterprise:*:*:* Versions 17.5.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.3.6, 17.4.3, 17.5.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.3.6, 17.4.3, 17.5.1
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-06329 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8312
- 2026-10-03 Alias added: GHSA-8r4j-q2x9-54v8
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-8312 · CVE Program
- CVE-2024-8312 · NVD
- FIRST EPSS
- GHSA-8r4j-q2x9-54v8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences