Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
An issue was discovered in GitLab EE affecting all versions starting from 17.2 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2. An input validation issue in the Google Cloud IAM integration feature could have enabled a Maintainer to introduce malicious code.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 17.2 to before 17.7.7; 17.8 to before 17.8.5; 17.9 to before 17.9.2 | 17.7.7, 17.8.5, 17.9.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 17.2 to before 17.7.7; 17.8 to before 17.8.5; 17.9 to before 17.9.2 Fixed in 17.7.7, 17.8.5, 17.9.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.2.0 to before 17.7.7; 17.8.0 to before 17.8.5; 17.9.0 to before 17.9.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.2.0 to before 17.7.7; 17.8.0 to before 17.8.5; 17.9.0 to before 17.9.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.7.7, 17.8.5, 17.9.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.7.7, 17.8.5, 17.9.2
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2024-11485 Generation of Error Message Containing Sensitive Information in GitLabPriority LOW 34
- TI-2025-01074 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 33
- TI-2024-12102 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8402
- 2026-10-03 Alias added: GHSA-xq5v-g7v7-8q74
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-8402 · CVE Program
- CVE-2024-8402 · NVD
- FIRST EPSS
- GHSA-xq5v-g7v7-8q74 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences