Concrete CMS version 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS versions 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block. A rogue administrator could add a malicious payload by executing it in the browsers of targeted users. The Concrete CMS Security Team gave this vulnerability a CVSS v4 score of 4.6 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Since the "Next&Previous Nav" block output was not sufficiently sanitized, the malicious payload could be executed in the browsers of targeted users. Thanks, Chu Quoc Khanh for reporting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concrete5/concrete5 (Packagist) | before 8.5.19 | 8.5.19 | Patch available | GHSA-xmxj-v2q8-8qx6 |
| — | concrete5/concrete5 (Packagist) | 9.0.0 to before 9.3.4 | 9.3.4 | Patch available | GHSA-xmxj-v2q8-8qx6 |
- concrete5/concrete5 (Packagist) Vendor— Affected before 8.5.19 Fixed in 8.5.19 Patch available GHSA-xmxj-v2q8-8qx6
- concrete5/concrete5 (Packagist) Vendor— Affected 9.0.0 to before 9.3.4 Fixed in 9.3.4 Patch available GHSA-xmxj-v2q8-8qx6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 8.5.19; 9.0 to before 9.3.4 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 8.5.19; 9.0 to before 9.3.4 Vulnerable ·Concrete CMS
Remediation
- Fix · GHSA-xmxj-v2q8-8qx6 concrete5/concrete5 (Packagist) Fixed in 8.5.19 Advisory →
- Fix · GHSA-xmxj-v2q8-8qx6 concrete5/concrete5 (Packagist) Fixed in 9.3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8661
- 2026-10-03 Alias added: GHSA-xmxj-v2q8-8qx6
References
Patch 2
Other 4
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/934-release-notes
- https://documentation.concretecms.org/developers/introduction/version-history/8519-release-notes
- https://github.com/concretecms/concretecms/commit/3e548b416ae32efee1e0a42c4510be1106c7eb25
- https://github.com/concretecms/concretecms
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-8661 · CVE Program
- CVE-2024-8661 · NVD
- FIRST EPSS
- GHSA-xmxj-v2q8-8qx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences