PAN-OS: Cleartext Exposure of GlobalProtect Portal Passcodes
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-497.
Summary
An information exposure vulnerability exists in Palo Alto Networks PAN-OS software that enables a GlobalProtect end user to learn both the configured GlobalProtect uninstall password and the configured disable or disconnect passcode. After the password or passcode is known, end users can uninstall, disable, or disconnect GlobalProtect even if the GlobalProtect app configuration would not normally permit them to do so.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 11.0.0 to before 11.0.1; 10.2.0 to before 10.2.4; 10.1.0 to before 10.1.9; 10.0.0 to before 10.0.12; 9.1.0 to before 9.1.16; 9.0.0 to before 9.0.17; 8.1.0 to before 8.1.25 | 11.1.0, 11.2.0, 11.0.1, 10.2.4, 10.1.9, 10.0.12, 9.1.16, 9.0.17, 8.1.25 | Patch available | CNA |
| Palo Alto Networks | GlobalProtect App | 5.1.0 to before 5.1.12; 5.2.0 to before 5.2.13; 6.0.0 to before 6.0.7; 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 | 5.1.12, 5.2.13, 6.0.7, 6.1.2, 6.2.1, 6.3.0 | Patch available | CNA |
| Palo Alto Networks | Cloud NGFW | — | All | Patch available | CNA |
| Palo Alto Networks | Prisma Access | 10.2.0 to before 10.2.9 on PAN-OS | 10.2.9 on PAN-OS | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 11.0.0 to before 11.0.1; 10.2.0 to before 10.2.4; 10.1.0 to before 10.1.9; 10.0.0 to before 10.0.12; 9.1.0 to before 9.1.16; 9.0.0 to before 9.0.17; 8.1.0 to before 8.1.25 Fixed in 11.1.0, 11.2.0, 11.0.1, 10.2.4, 10.1.9, 10.0.12, 9.1.16, 9.0.17, 8.1.25 Patch available CNA
- GlobalProtect App VendorPalo Alto Networks Affected 5.1.0 to before 5.1.12; 5.2.0 to before 5.2.13; 6.0.0 to before 6.0.7; 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 Fixed in 5.1.12, 5.2.13, 6.0.7, 6.1.2, 6.2.1, 6.3.0 Patch available CNA
- Cloud NGFW VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected 10.2.0 to before 10.2.9 on PAN-OS Fixed in 10.2.9 on PAN-OS Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.25; 9.0.0 to before 9.0.17; 9.1.0 to before 9.1.16; 10.0.0 to before 10.0.12; 10.1.0 to before 10.1.9; 10.2.0 to before 10.2.4 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:o:paloaltonetworks:pan-os:11.0.0:*:*:*:*:*:*:* | 11.0.0 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:a:paloaltonetworks:globalprotect:*:*:*:*:*:*:*:* | 5.1.0 to before 5.1.12; 5.2.0 to before 5.2.13; 6.0.0 to before 6.0.7; 6.1.0 to before 6.1.2 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:a:paloaltonetworks:globalprotect:6.2.0:*:*:*:*:*:*:* | 6.2.0 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:a:paloaltonetworks:prisma_access:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | before 10.2.9 | Running on | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.25; 9.0.0 to before 9.0.17; 9.1.0 to before 9.1.16; 10.0.0 to before 10.0.12; 10.1.0 to before 10.1.9; 10.2.0 to before 10.2.4 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:o:paloaltonetworks:pan-os:11.0.0:*:*:*:*:*:*:* Versions 11.0.0 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:a:paloaltonetworks:globalprotect:*:*:*:*:*:*:*:* Versions 5.1.0 to before 5.1.12; 5.2.0 to before 5.2.13; 6.0.0 to before 6.0.7; 6.1.0 to before 6.1.2 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:a:paloaltonetworks:globalprotect:6.2.0:*:*:*:*:*:*:* Versions 6.2.0 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:a:paloaltonetworks:prisma_access:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions before 10.2.9 Running on ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 11.1.0, 11.2.0, 11.0.1, 10.2.4, 10.1.9, 10.0.12, 9.1.16, 9.0.17, 8.1.25
- Fix · CNA GlobalProtect App (Palo Alto Networks) Fixed in 5.1.12, 5.2.13, 6.0.7, 6.1.2, 6.2.1, 6.3.0
- Fix · CNA Cloud NGFW (Palo Alto Networks) Fixed in All
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in 10.2.9 on PAN-OS
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8687
- 2026-10-03 Alias added: GHSA-r589-95v2-93xr
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-8687 · CVE Program
- CVE-2024-8687 · NVD
- FIRST EPSS
- GHSA-r589-95v2-93xr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences