Cross-site scripting in Docker Desktop
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A remote code execution (RCE) vulnerability via crafted extension publisher-url/additional-urls could be abused by a malicious extension in Docker Desktop before 4.34.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Docker Desktop (Docker) Fixed in 4.34.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Docker Desktop 4.34.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-08065 Cross-site scripting in Docker DesktopPriority MEDIUM 43
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8696
- 2026-10-03 Alias added: GHSA-2hm7-3qf5-g28w
References
More Docker Desktop vulnerabilities
- TI-2025-02823 Elevation of Privilege in Docker Desktop for Windows during Upgrade due to Insecure Directory Deletion CVSS 4.0HIGH 7.3
- TI-2024-08065 Cross-site scripting in Docker Desktop CVSS 4.0CRITICAL 9.0
- TI-2022-17400 Docker Desktop for Windows before 4.6.0 allows attackers to delete (or create) any file… CVSS 3.1HIGH 7.8
- TI-2021-15651 Docker Desktop before 3.6.0 suffers from incorrect access control. CVSS 3.1HIGH 7.8
- TI-2024-05770 In Docker Desktop before v4.29.0 an attacker who has gained access to the Docker Desktop… CVSS 4.0HIGH 7.3
- TI-2023-01694 Cleartext transmission of sensitive information in Docker Desktop CVSS 3.1HIGH 7.5
Sources
- CVE-2024-8696 · CVE Program
- CVE-2024-8696 · NVD
- FIRST EPSS
- GHSA-2hm7-3qf5-g28w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences