Quform - WordPress Form Builder <= 2.20.0 - Unauthenticated Sensitive Information Exposure
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ThemeCatcher | Quform - WordPress Form Builder | up to 2.20.0 | — | No fix listed | CNA |
- Quform - WordPress Form Builder VendorThemeCatcher Affected up to 2.20.0 Fixed in — No fix listed CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themecatcher:quform:*:*:*:*:*:*:*:* | — | — | ThemeCatcher |
- cpe:2.3:a:themecatcher:quform:*:*:*:*:*:*:*:* Versions — — ·ThemeCatcher
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8756
- 2026-10-03 Alias added: GHSA-g7pq-m585-vmf6
References
More ThemeCatcher vulnerabilities
- TI-2026-40451 WordPress Quform plugin <= 2.23.0 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-8756 · CVE Program
- CVE-2024-8756 · NVD
- FIRST EPSS
- GHSA-g7pq-m585-vmf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences